IMNZ has recently launched training in an online format for some of our more popular courses like Elevate, Finance for Non-Financial Managers, Project Management Essentials and Team Leader Essentials. Like with most online learning platforms, there are certain requirements your web browser needs to meet in order to have a great user experience. These terms and technical requirements have been laid out below for you.



Browser requirements

IMNZ’s e-learning programmes are compatible with all standard’s compatible web browsers, however, for the best experience, we recommend using Chrome.

We recommend that you keep your web browser up to date for not only the best experience but also to optimise your online security.

Out-dated browsers with known compatibility problems are Internet Explorer 10 and below as well as Safari 7 and below.

Users must Allow Pop-ups to view the content.



What else you need to know

When you log into IMNZ’s online platform, you must use the same as the email address that you registered with. You must also use the same address when you use MS Teams as part of your training.

IMNZ’s online platform operates off Moodle. You may need to check with your company’s IT department that your firewall will allow access to Moodle.